Since A2007, the maximum length of a password has been 20 characters.
See https://support.microsoft.com/en-us/office/access-specifications-0cf3c66f-9cf2-4e32-9568-98c1025bb47c

You can create a password of longer than 20 characters
However, only the first 20 characters are actually used. 
Anything after that is ignored


However whilst you can successfully link to a database with a 20 character password,
attempting to open the linked table(s) generates the ‘not a valid password’ error

The maximum usable length is therefore 19 characters
=================================================

abcdefghijklmnopqrs
19


abcdefghijklmnopqrst
20


abcdefghijklmnopqrstuvwxyz
26
This is also treated as 20 characters



